Saturday, September 12, 2015

ERROR: Missing requirement: Oozie Eclipse Plugin requires 'org.eclipse.gef 3.10.0' but it could not be found

If, during installation, you get this error message (or a similar error message):

Cannot complete the install because one or more required items could not be found. Software being installed: Oozie Eclipse Plugin 0.1.0.201508312352 (com.mashin.oep.feature.feature.group 0.1.0.201508312352) Missing requirement: Oozie Eclipse Plugin 0.1.0.201508312352 (com.mashin.oep.feature.feature.group 0.1.0.201508312352) requires 'org.eclipse.gef 3.10.0' but it could not be found
Then, you should manually install the required dependency.

Installing the Graphical Editing Framework (GEF) dependency (org.eclipse.gef 3.10.0)


  1. Go to Help -> Install New Software...


  2. Add this site "http://download.eclipse.org/tools/gef/updates/releases/", select "GEF (Graphical Editing Framework" and continue GEF installation.


  3. Re-install Oozie Eclipse Plugin


3 comments:

  1. Cannot complete the install because one or more required items could not be found. Software being installed: Oozie Eclipse Plugin 0.1.0.201508312352. Oneclipse.com

    ReplyDelete
    Replies
    1. It seems you are installing an older version of the plugin. The latest version is 0.3.4.201602061635.
      You may follow the instructions there http://blog.oep.mashin.io/2015/09/install-oozie-eclipse-plugin.html

      Delete
  2. Thanks for the post. It helped a lot.

    ReplyDelete